圣天诺·Sentinel LDK v7.10发布啦!进一步支持了许可自动化升级,快来全面了解!!

2019/09/03 软件货币化 31

Sentinel LDK v.7.10有什么新功能?


本节介绍主要的新功能和增强功能

注意:如果要从早于v.7.9的Sentinel LDK版本升级,请务必查看所有介入版本的发行说明。每个版本的Sentinel LDK都引入了重要的增强和更改。

Sentinel EMS现在简化了许可证更新的在线应用

最终用户现在只需访问Sentinel EMS客户门户并单击“ 更新许可证”按钮,即可对其计算机上的一个或多个保护锁应用多个更新。无需登录。当用户单击“ 更新许可证”按钮时,Sentinel EMS将检查用户本地计算机上的每个保护锁,并应用供应商为该密钥颁发的所有未完成的许可证更新。


软件加密狗,软件加密锁,加密圣天狗,身份认证Ikey,AladdinHasp,Superdog超级狗,Sentinel

使用此方法,最终用户无需在其计算机上应用V2C文件。颁发许可证更新时,您只需指示最终用户访问客户门户。

注意    

必须在最终用户的计算机上安装运行环境版本7.100或更高版本。

“许可证更新”选项卡不能用于将许可证更新应用于SL旧版密钥。

Sentinel EMS的其他增强功能

客户门户的其他改进

  您现在可以在iFrame中将Sentinel EMS客户门户直接添加到您的站点。这样,您就可以将您的客户留在您的网站上。有关详细信息,请参阅“ Sentinel LDK-EMS配置指南”。

改进了Sentinel EMS屏幕中的搜索功能

  以前,当您在任何Sentinel EMS屏幕中搜索字符串时,如果您的搜索字符串包含多个术语,Sentinel EMS使用OR运算符返回包含任何指定术语的所有记录。结果,返回了许多不相关的记录。例如,搜索字符串“墨尔本大学”返回了诸如“墨尔本部”和“特伦特大学”的记录。

现在,Sentinel EMS使用AND运算符进行这些搜索。因此,仅返回包含所有重要搜索词的记录。

此外,您现在可以搜索同一术语的多个实例以返回所有相关条目,而不管术语出现的次数。例如,搜索字符串“jo jo”现在将返回“Joseph Smith”,“Joelle Joy Johnson”和“Cup of Joe”

自定义报告

  您现在可以将自定义报告的可见性限制为具有特定批代码权限的用户。有关详细信息,请参阅“ Sentinel LDK-EMS用户指南”中有关自定义报告的部分。

Recycled Sentinel HL钥匙现在可以重复用于其他客户

  现在,使用Sentinel EMS中的“ 回收密钥”功能可以安全地为任何客户重复使用回收的Sentinel HL密钥。回收HL密钥会删除指定密钥和客户之间的所有链接。此外,回收HL密钥会完全删除密钥中的许可证数据以及来自Sentinel EMS的任何未完成的订单数据。

渠道合作伙伴的新Web服务

  添加了几个新的Sentinel EMS Web服务以支持渠道合作伙伴。现在可以使用创建,检索,搜索,更新和删除渠道合作伙伴等功能。有关更多详细信息,请参阅Sentinel LDK - EMS Web服务指南。

(可选)强制使用最低版本的运行时环境

  此增强功能包含在Sentinel LDK v.7.9更新中。

  Sentinel LDK Envelope和Sentinel Licensing API使用为您的供应商代码定制的API库来保护您的应用程序。这些库由Gemalto专门为您的批处理代码生成。在介绍供应商密钥时,可以使用主向导下载这些自定义供应商库。

主向导现在为您提供两种类型的库选择,每种库都包含下面描述的选项之一。您选择的选项确定受保护的应用程序与运行时环境(RTE)的交互方式。可用选项包括:

版本限制选项(建议在受保护应用程序中获得最佳安全性和可靠性)

  对于需要RTE的受保护应用程序:使用版本限制选项,应用程序将需要最低版本的RTE(包含最新重要安全性和可靠性增强功能的最早版本)。使用版本限制选项可确保最终用户无法降级到早期版本的RTE,并且他们使用提供最佳质量的RTE版本以及所有最新的安全性和可靠性修复程序。此限制既适用于RTE的本地部署,也适用于在远程许可证服务器计算机上部署RTE。

对于Sentinel LDK的每个新版本,仅当该版本的RTE包含重要的安全性和可靠性增强功能时,才会更新所需的最低版本号。

  例如:受版本7.9或7.10自定义供应商库保护的应用程序所需的RTE 最低版本仍为RTE版本7.90,因为此版本的RTE包含最新的重要安全性和可靠性增强功能。RTE的更高版本包含不太重要的增强和修复。

版本无限制选项(与所有版本的RTE兼容)

  对于需要运行环境的受保护应用程序:应用程序不会检查RTE的版本号。使用此选项保护的应用程序可以与所有版本的RTE一起使用。仅当您要避免在最终用户站点升级RTE时,才选择此选项。此选项简化了部署,尤其是在使用网络许可证服务器时,但不保证在以后的RTE版本中使用安全性和可靠性修复。

下图说明了此过程:


软件加密狗,软件加密锁,加密圣天狗,身份认证Ikey,AladdinHasp,Superdog超级狗,Sentinel


注意   如果受保护的应用程序使用需要更高版本RTE的特定功能,则无论使用哪一个选项,用户都需要升级其RTE。

有关详细信息,请参阅“ Sentinel LDK软件保护和授权指南 ”中的“运行时环境的必需版本”。

在Linux下增强对Docker容器中受保护应用程序的支持

  您现在可以在Linux下的Docker容器中安装Sentinel LDK运行环境和某些SL密钥。现在可以使用新的克隆保护方案(VMType4)来保护在Docker容器中执行的应用程序。

有关详细信息,请参阅“ Sentinel LDK软件保护和授权指南”。

添加了对.NET核心程序集的支持

  Sentinel LDK现在支持使用Sentinel LDK Envelope在Windows平台上保护版本2.1和2.2的.NET Core程序集。.NET Core仅包含与平台无关的功能。因此,所有特定于平台的功能(例如GUI)都不可用,并且存在某些限制。

  例如,所有类型的Envelope生成的消息框都不起作用(因为它们基于System.Windows.Forms.Messagebox或自定义形式的System.Windows.Forms。此外,.NET Core主要适用于服务器侧面应用程序,可能根本没有任何GUI。由于缺少消息框支持,所有输出消息将仅在控制台中记录。

  有关详细信息,请参阅Sentinel LDK Envelope帮助系统。

改进了对计算机恢复软件的防护

  计算机恢复软件的使用提供了滥用某些类型的受保护应用程序的能力。在计算机上检测到计算机还原软件时,如果满足以下任一条件,则不允许在虚拟机上运行的受保护应用程序现在返回错误代码HASP_VS_DETECTED:许可证类型是到期日期,执行或时间段。

许可证允许分离或重新托管操作。

  Sentinel LDK Envelope中新的可自定义的最终用户消息与Sentinel LDK Envelope中的以下保护设置相关的消息现在包含在可自定义的消息文件中:

许可证检查失败后允许宽限期

  运行时等待添加了消息ID 5001到5007,可以自定义。Envelope支持将非ASCII字符用于自定义消息。(在当前版本中,这些消息只能针对本机Windows应用程序进行自定义。对于Java或.NET应用程序,这些消息无法自定义。)

针对Linux的Sentinel LDK Envelope的增强功能

  适用于Linux的Sentinel LDK Envelope已增强如下:

  使用新配置和行命令参数可以禁用受保护应用程序中特定ELF二进制部分的加密。如果某些部分影响不支持交换区域的设备上的运行时性能(就内存消耗而言),这将非常有用。

  现在,Sentinel LDK Envelope for Linux通过指定外部模块的Envelope运行时路径名来支持某些uClibc模块。可以根据需要提供此支持。请联系技术支持以获取支持的外部模块列表和包裹交付。

dfcrypt实用程序的增强功能

  用于加密和保护数据文件的dfcrypt line-command实用程序已增强如下:

  • Linux Intel平台现在支持dfcrypt,以使用版本2数据文件保护模式保护数据文件。Linux Intel或Linux ARM下的Linux应用程序可以访问(但不更新)受保护的文件。

  • 在Windows或Linux 下使用dfcrypt中的版本2数据文件保护模式保护数据时,您现在可以指定要使用的加密密钥(最多16个字符)。如果未指定加密密钥,则会生成随机密钥。受保护的应用程序不需要加密密钥即可访问受保护的数据文件。

适用于Linux的许可证生成API现已包含在Sentinel LDK安装驱动器中

  适用于Linux的Sentinel许可证生成API现在可在Sentinel LDK安装驱动器中使用,包括C样本(32位和64位)。请参阅\ Linux \ API \ Licgen。


电话咨询
邮件咨询
在线地图
QQ客服